using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?<!\.)(?<!\-)(?!^)\d{3}(?:\b|(?:\d{3})+)\b)";
string substitution = @",";
string input = @"1234
123
1234.123
1234123
1234123534
0.123
-1234
-123456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}