import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^.*?=";
final String string = "ErrorMoving=You cannot=another.\n"
+ "ErrorTooMuchActions\n"
+ "=Too many changes=.{k}=12=aa\n"
+ "WorldErrorWait=An error has occurred.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}