// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?m)^.*?=").unwrap();
let string = "ErrorMoving=You cannot=another.
ErrorTooMuchActions
=Too many changes=.{k}=12=aa
WorldErrorWait=An error has occurred.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}