use strict;
my $str = 'ErrorMoving=You cannot=another.
ErrorTooMuchActions
=Too many changes=.{k}=12=aa
WorldErrorWait=An error has occurred.';
my $regex = qr/(?m)^.*?=/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";