re = /(?m)^.*?=/m
str = 'ErrorMoving=You cannot=another.
ErrorTooMuchActions
=Too many changes=.{k}=12=aa
WorldErrorWait=An error has occurred.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result