using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http|ftp)s?:\/\/\S*\.\S*(?=""|<)";
string input = @"Here is some content and url <p>http://www.something.com/index.html</p>
<p>Some more content <a href=""http://www.something.com/some/path/here.html"">http://www.something.com/some/path/here.html</a></p>
Some more text http://www.something.com/something/somethingelse.html content continued...";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}