import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http|ftp)s?:\\/\\/\\S*\\.\\S*(?=\"|<)";
final String string = "Here is some content and url <p>http://www.something.com/index.html</p>\n"
+ "<p>Some more content <a href=\"http://www.something.com/some/path/here.html\">http://www.something.com/some/path/here.html</a></p>\n"
+ "Some more text http://www.something.com/something/somethingelse.html content continued...";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}