# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:http|ftp)s?:\/\/\S*\.\S*(?=\"|<)"
test_str = ("Here is some content and url <p>http://www.something.com/index.html</p>\n"
"<p>Some more content <a href=\"http://www.something.com/some/path/here.html\">http://www.something.com/some/path/here.html</a></p>\n"
"Some more text http://www.something.com/something/somethingelse.html content continued...")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.