re = /(?:http|ftp)s?:\/\/\S*\.\S*(?="|<)/i
str = 'Here is some content and url <p>http://www.something.com/index.html</p>
<p>Some more content <a href="http://www.something.com/some/path/here.html">http://www.something.com/some/path/here.html</a></p>
Some more text http://www.something.com/something/somethingelse.html content continued...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end