$re = '/(?:http|ftp)s?:\/\/\S*\.\S*(?="|<)/i';
$str = 'Here is some content and url <p>http://www.something.com/index.html</p>
<p>Some more content <a href="http://www.something.com/some/path/here.html">http://www.something.com/some/path/here.html</a></p>
Some more text http://www.something.com/something/somethingelse.html content continued...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);