#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*?)_(.*)"
Local $sString = "org.apache.commons.httpclient_3.1.0.v20170718_1537" & @CRLF & _
"org.apache.commons.httpclient_3.1.0.v20170718-1537" & @CRLF & _
"org.apache.james.mime4j_0.6.0.v20120423"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")