const regex = /(.*?)_(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)_(.*)', 'gm')
const str = `org.apache.commons.httpclient_3.1.0.v20170718_1537
org.apache.commons.httpclient_3.1.0.v20170718-1537
org.apache.james.mime4j_0.6.0.v20120423`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}