import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)_(.*)";
final String string = "org.apache.commons.httpclient_3.1.0.v20170718_1537\n"
+ "org.apache.commons.httpclient_3.1.0.v20170718-1537\n"
+ "org.apache.james.mime4j_0.6.0.v20120423";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}