package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?)_(.*)`)
var str = `org.apache.commons.httpclient_3.1.0.v20170718_1537
org.apache.commons.httpclient_3.1.0.v20170718-1537
org.apache.james.mime4j_0.6.0.v20120423`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}