$re = '/(.*?)_(.*)/m';
$str = 'org.apache.commons.httpclient_3.1.0.v20170718_1537
org.apache.commons.httpclient_3.1.0.v20170718-1537
org.apache.james.mime4j_0.6.0.v20120423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);