# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\/([^\s\/]+\.pdf)/replacement $1/gm;t' <<< "/a.pdf
/abc.def.pdf
/a/b.pdf"