$re = '`^/([^\s/]+\.pdf)`m';
$str = '/a.pdf
/abc.def.pdf
/a/b.pdf';
$subst = "replacement $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;