import Foundation
let pattern = #"^/([^\s/]+\.pdf)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/a.pdf
/abc.def.pdf
/a/b.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replacement $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)