const regex = new RegExp('^/([^\\s/]+\\.pdf)', 'gm')
const str = `/a.pdf
/abc.def.pdf
/a/b.pdf`;
const subst = `replacement $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);