#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^a\n\r]*\b([^\Wa]*a\w*)"
Local $sString = "The cat ate the dog" & @CRLF & _
"and the mouse" & @CRLF & _
"" & @CRLF & _
"this is a test" & @CRLF & _
"a" & @CRLF & _
"when will this be matching?" & @CRLF & _
"@!#SSDF2#$@a#$dsfs$sdfdsdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")