package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^a\n\r]*\b([^\Wa]*a\w*)`)
var str = `The cat ate the dog
and the mouse
this is a test
a
when will this be matching?
@!#SSDF2#$@a#$dsfs$sdfdsdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}