re = /^[^a\n\r]*\b([^\Wa]*a\w*)/m
str = 'The cat ate the dog
and the mouse
this is a test
a
when will this be matching?
@!#SSDF2#$@a#$dsfs$sdfdsdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end