// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^a\n\r]*\b([^\Wa]*a\w*)").unwrap();
let string = "The cat ate the dog
and the mouse
this is a test
a
when will this be matching?
@!#SSDF2#$@a#$dsfs$sdfdsdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}