use strict;
my $str = '{code}
UPDATE tenants SET end_user_uuid = \'32392464c8a19a15dd8dc982ae3d574b\' WHERE end_user_uuid = \'9e194bfeace6c2d17cc71cc15e84f93a\' AND instance_id = \'265358\' AND domain = \'automobieljansen\';
{code}';
my $regex = qr/\{code\}(.*?)\{code\}/msp;
my $subst = '<pre>$1</pre>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";