re = /\{code\}(.*?)\{code\}/m
str = '{code}
UPDATE tenants SET end_user_uuid = \'32392464c8a19a15dd8dc982ae3d574b\' WHERE end_user_uuid = \'9e194bfeace6c2d17cc71cc15e84f93a\' AND instance_id = \'265358\' AND domain = \'automobieljansen\';
{code}'
subst = '<pre>$1</pre>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result