use strict;
my $str = ' E9:F18 M17 M17 X1:H8
F105 S34 X1:H8
F31:X1 Q1:X1 W3 ';
my $regex = qr/(^[ ]{1,})|([ ]{1,}$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";