import Foundation
let pattern = #"(^[ ]{1,})|([ ]{1,}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
E9:F18 M17 M17 X1:H8
F105 S34 X1:H8
F31:X1 Q1:X1 W3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)