import re
regex = re.compile(r"(^[ ]{1,})|([ ]{1,}$)", flags=re.MULTILINE)
test_str = (" E9:F18 M17 M17 X1:H8 \n"
"F105 S34 X1:H8\n"
"F31:X1 Q1:X1 W3 ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)