# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?=Medication|Administration|Record )\b(.)(?>edication |dministration |ecord ))/$1/gs;t' <<< " Medication Administration Record
"