$re = '/(?:(?=Medication|Administration|Record )\b(.)(?>edication |dministration |ecord ))/s';
$str = ' Medication Administration Record
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;