re = /(?:(?=Medication|Administration|Record )\b(.)(?>edication |dministration |ecord ))/
str = ' Medication Administration Record
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result