use strict;
my $str = ' Medication Administration Record
';
my $regex = qr/(?:(?=Medication|Administration|Record )\b(.)(?>edication |dministration |ecord ))/sp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";