using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\S\n]*(\S+)[^\S\n]{2,}([\d,]+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(\d+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(up|down)+[^\S\n]{2,}(up|down)+[^\S\n]{2,}([\w +?]+)[^\S\n]{2,}(\S+)";
string input = @" admin@str-s6000-on-5:~$ show interface status Ethernet4
Interface Lanes Speed MTU Alias Vlan Oper Admin Type Asym PFC
--------------- ----------- ------- ----- ------------ ------ ------ ------- -------------- ----------
Ethernet4 29,30,31,32 40G 9100 fortyGigE0/4 trunk up up QSFP+ or later off
PortChannel0001 N/A 40G 9100 N/A routed up up N/A N/A
PortChannel0002 N/A 40G 9100 N/A routed up up N/A N/A
PortChannel0003 N/A 40G 9100 N/A routed up up N/A N/A
PortChannel0004 N/A 40G 9100 N/A routed up up N/A N/A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}