re = /^[^\S\n]*(\S+)[^\S\n]{2,}([\d,]+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(\d+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(up|down)+[^\S\n]{2,}(up|down)+[^\S\n]{2,}([\w +?]+)[^\S\n]{2,}(\S+)/m
str = ' admin@str-s6000-on-5:~$ show interface status Ethernet4
Interface Lanes Speed MTU Alias Vlan Oper Admin Type Asym PFC
--------------- ----------- ------- ----- ------------ ------ ------ ------- -------------- ----------
Ethernet4 29,30,31,32 40G 9100 fortyGigE0/4 trunk up up QSFP+ or later off
PortChannel0001 N/A 40G 9100 N/A routed up up N/A N/A
PortChannel0002 N/A 40G 9100 N/A routed up up N/A N/A
PortChannel0003 N/A 40G 9100 N/A routed up up N/A N/A
PortChannel0004 N/A 40G 9100 N/A routed up up N/A N/A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end