import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\S\\n]*(\\S+)[^\\S\\n]{2,}([\\d,]+)[^\\S\\n]{2,}(\\S+)[^\\S\\n]{2,}(\\d+)[^\\S\\n]{2,}(\\S+)[^\\S\\n]{2,}(\\S+)[^\\S\\n]{2,}(up|down)+[^\\S\\n]{2,}(up|down)+[^\\S\\n]{2,}([\\w +?]+)[^\\S\\n]{2,}(\\S+)";
final String string = " admin@str-s6000-on-5:~$ show interface status Ethernet4\n"
+ " Interface Lanes Speed MTU Alias Vlan Oper Admin Type Asym PFC\n"
+ "--------------- ----------- ------- ----- ------------ ------ ------ ------- -------------- ----------\n"
+ " Ethernet4 29,30,31,32 40G 9100 fortyGigE0/4 trunk up up QSFP+ or later off\n"
+ "PortChannel0001 N/A 40G 9100 N/A routed up up N/A N/A\n"
+ "PortChannel0002 N/A 40G 9100 N/A routed up up N/A N/A\n"
+ "PortChannel0003 N/A 40G 9100 N/A routed up up N/A N/A\n"
+ "PortChannel0004 N/A 40G 9100 N/A routed up up N/A N/A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}