# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\S\n]*(\S+)[^\S\n]{2,}([\d,]+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(\d+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(\S+)[^\S\n]{2,}(up|down)+[^\S\n]{2,}(up|down)+[^\S\n]{2,}([\w +?]+)[^\S\n]{2,}(\S+)"
test_str = (" admin@str-s6000-on-5:~$ show interface status Ethernet4\n"
" Interface Lanes Speed MTU Alias Vlan Oper Admin Type Asym PFC\n"
"--------------- ----------- ------- ----- ------------ ------ ------ ------- -------------- ----------\n"
" Ethernet4 29,30,31,32 40G 9100 fortyGigE0/4 trunk up up QSFP+ or later off\n"
"PortChannel0001 N/A 40G 9100 N/A routed up up N/A N/A\n"
"PortChannel0002 N/A 40G 9100 N/A routed up up N/A N/A\n"
"PortChannel0003 N/A 40G 9100 N/A routed up up N/A N/A\n"
"PortChannel0004 N/A 40G 9100 N/A routed up up N/A N/A")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.