#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\D+)(\((\d+)\))?\s(\+(\d+)⚔)?\s?(\+(\d+)🛡)? \/(on|off)_(\d+)"
Local $sString = "Мифриловая броня(3) +1⚔ +9🛡 /off_112" & @CRLF & _
"Мифриловые сапоги +6🛡 /off_132" & @CRLF & _
"Стальные перчатки(1) +3🛡 /on_135" & @CRLF & _
"Стальные сапоги(1) +3🛡 /on_130"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")