# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\D+)(\((\d+)\))?\s(\+(\d+)⚔)?\s?(\+(\d+)🛡)? \/(on|off)_(\d+)"
test_str = ("Мифриловая броня(3) +1⚔ +9🛡 /off_112\n"
"Мифриловые сапоги +6🛡 /off_132\n"
"Стальные перчатки(1) +3🛡 /on_135\n"
"Стальные сапоги(1) +3🛡 /on_130")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.