import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\D+)(\\((\\d+)\\))?\\s(\\+(\\d+)⚔)?\\s?(\\+(\\d+)🛡)? \\/(on|off)_(\\d+)";
final String string = "Мифриловая броня(3) +1⚔ +9🛡 /off_112\n"
+ "Мифриловые сапоги +6🛡 /off_132\n"
+ "Стальные перчатки(1) +3🛡 /on_135\n"
+ "Стальные сапоги(1) +3🛡 /on_130";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}