const regex = /(\D+)(\((\d+)\))?\s(\+(\d+)⚔)?\s?(\+(\d+)🛡)? \/(on|off)_(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\D+)(\\((\\d+)\\))?\\s(\\+(\\d+)⚔)?\\s?(\\+(\\d+)🛡)? \\\/(on|off)_(\\d+)', 'g')
const str = `Мифриловая броня(3) +1⚔ +9🛡 /off_112
Мифриловые сапоги +6🛡 /off_132
Стальные перчатки(1) +3🛡 /on_135
Стальные сапоги(1) +3🛡 /on_130`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}