use strict;
my $str = 'Мифриловая броня(3) +1⚔ +9🛡 /off_112
Мифриловые сапоги +6🛡 /off_132
Стальные перчатки(1) +3🛡 /on_135
Стальные сапоги(1) +3🛡 /on_130';
my $regex = qr/(\D+)(\((\d+)\))?\s(\+(\d+)⚔)?\s?(\+(\d+)🛡)? \/(on|off)_(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}