import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n*\\d+:\\d+:\\d+\\.\\d+,\\d+:\\d+:\\d+\\.\\d+\\n(.*)";
final String string = "0:04:10.700,0:04:11.360\n"
+ "but\n\n"
+ "0:04:11.360,0:04:15.680\n"
+ "but it was plenty big you know the silo itself would have easily been\n\n"
+ "0:04:16.180,0:04:18.420\n"
+ "as wide as this room is\n\n"
+ "0:04:18.420,0:04:23.200\n"
+ "and perhaps larger and many, many, story's tall, you know because it was nested underground";
final String subst = "$1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}