import re
regex = re.compile(r"\n*\d+:\d+:\d+\.\d+,\d+:\d+:\d+\.\d+\n(.*)")
test_str = ("0:04:10.700,0:04:11.360\n"
"but\n\n"
"0:04:11.360,0:04:15.680\n"
"but it was plenty big you know the silo itself would have easily been\n\n"
"0:04:16.180,0:04:18.420\n"
"as wide as this room is\n\n"
"0:04:18.420,0:04:23.200\n"
"and perhaps larger and many, many, story's tall, you know because it was nested underground")
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)