using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^\n""]*?\bhello\b[^\n""]*""|(\bhello\b)";
string input = @"""hello""
""testing... hello world""
hello
""hello
hello""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}