$re = '/"[^\n"]*?\bhello\b[^\n"]*"|(\bhello\b)/';
$str = '"hello"
"testing... hello world"
hello
"hello
hello"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);