re = /"[^\n"]*?\bhello\b[^\n"]*"|(\bhello\b)/
str = '"hello"
"testing... hello world"
hello
"hello
hello"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end