#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/\/[^"\n\r]*(?:"[^"\n\r]*"[^"\n\r]*)*[\r\n]|\/\*([^*]|\*(?!\/))*?\*\/)(?=[^"]*(?:"[^"]*"[^"]*)*$)"
Local $sString = "hey = "//comment" //comment "" & @CRLF & _
"hey = "//comment" //comment " & @CRLF & _
"hey = "/" //comment"" & @CRLF & _
"//" & @CRLF & _
""//"/"" & @CRLF & _
"# complete line should be found" & @CRLF & _
"//comment" & @CRLF & _
"lorem ipsum # from this to line end" & @CRLF & _
"/*" & @CRLF & _
" all three lines should be found" & @CRLF & _
"*/ but not here anymore" & @CRLF & _
"var x = \\"this # should not be found\\"" & @CRLF & _
"var y = \\"this /* shouldn\\'t */ match either\\"" & @CRLF & _
"var z = \\"but\\" & /* this must match */ \\"_\\"" & @CRLF & _
"Argh! what about a \\"multiline string\\\\" & @CRLF & _
"with a # mark\\\\" & @CRLF & _
"int it ?! \\"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")