const regex = /(\/\/[^"\n\r]*(?:"[^"\n\r]*"[^"\n\r]*)*[\r\n]|\/\*([^*]|\*(?!\/))*?\*\/)(?=[^"]*(?:"[^"]*"[^"]*)*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/[^"\\n\\r]*(?:"[^"\\n\\r]*"[^"\\n\\r]*)*[\\r\\n]|\\\/\\*([^*]|\\*(?!\\\/))*?\\*\\\/)(?=[^"]*(?:"[^"]*"[^"]*)*$)', 'gm')
const str = `hey = "//comment" //comment "
hey = "//comment" //comment
hey = "/" //comment"
//
"//"/"
# complete line should be found
//comment
lorem ipsum # from this to line end
/*
all three lines should be found
*/ but not here anymore
var x = \\\\"this # should not be found\\\\"
var y = \\\\"this /* shouldn\\\\'t */ match either\\\\"
var z = \\\\"but\\\\" & /* this must match */ \\\\"_\\\\"
Argh! what about a \\\\"multiline string\\\\\\\\
with a # mark\\\\\\\\
int it ?! \\\\"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}