import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/[^\"\\n\\r]*(?:\"[^\"\\n\\r]*\"[^\"\\n\\r]*)*[\\r\\n]|\\/\\*([^*]|\\*(?!\\/))*?\\*\\/)(?=[^\"]*(?:\"[^\"]*\"[^\"]*)*$)";
final String string = "hey = \"//comment\" //comment \"\n"
+ "hey = \"//comment\" //comment \n"
+ "hey = \"/\" //comment\"\n"
+ "//\n"
+ "\"//\"/\"\n"
+ "# complete line should be found\n"
+ "//comment\n"
+ "lorem ipsum # from this to line end\n"
+ "/*\n"
+ " all three lines should be found\n"
+ "*/ but not here anymore\n"
+ "var x = \\\\\"this # should not be found\\\\\"\n"
+ "var y = \\\\\"this /* shouldn\\\\'t */ match either\\\\\"\n"
+ "var z = \\\\\"but\\\\\" & /* this must match */ \\\\\"_\\\\\"\n"
+ "Argh! what about a \\\\\"multiline string\\\\\\\\\n"
+ "with a # mark\\\\\\\\\n"
+ "int it ?! \\\\\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}