using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/[^""\n\r]*(?:""[^""\n\r]*""[^""\n\r]*)*[\r\n]|\/\*([^*]|\*(?!\/))*?\*\/)(?=[^""]*(?:""[^""]*""[^""]*)*$)";
string input = @"hey = ""//comment"" //comment ""
hey = ""//comment"" //comment
hey = ""/"" //comment""
//
""//""/""
# complete line should be found
//comment
lorem ipsum # from this to line end
/*
all three lines should be found
*/ but not here anymore
var x = \\""this # should not be found\\""
var y = \\""this /* shouldn\\'t */ match either\\""
var z = \\""but\\"" & /* this must match */ \\""_\\""
Argh! what about a \\""multiline string\\\\
with a # mark\\\\
int it ?! \\""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}